XP如何发现IP地址冲突

   在以太网中经常遇到“IP地址与网络上的其他系统有冲突”情况,本文只探讨XP发现冲突的过程,不提供解决方案。

   下面我们来模拟制造一个冲突的过程来了解奇发现冲突的过程。

工具:sniffer pro (去网上找吧笔者用的是4.70.530汉化版)
装上以后重启计算机,运行sniffer pro ,选择网卡,进入主程序,选择捕获菜单(ALT+C)—>定义过滤器(D)—>高级,然后启中ARP。我们只捕获ARP就行了。

下边开始抓包,点sniffer pro菜单下边的倒▲开始抓ARP的包。
然后我们去改本地网卡的IP地址,这时本机会向外发送ARP通告(广播)以说明自已IP的变动,这样就捕到了三个ARP的包。然后点sniffer中带有望远镜的■按扭,停止并显示结果,在弹出的窗口中的左下角上选“解码”。就可以看到ARP的包。在中间区块中打开折叠的帧,找到
ARP:Sender's hardware address=00e04c002bae(不同网卡MAC地址不同)
ARP:Sender's protocol address=[10.1.1.3]
我们只要将第一行中的MAC地址改为别的,然后把该帧发送出去(广播),本机就会提示“IP地址与网络上的其他系统有冲突”,因为他收到了一个发送者MAC地址与自已不同,而IP确相同的帧,则认为网络上另一台机子的IP与本机相同。
好我们在该帧上右击,选“发送当前帧”将光标移至Sender's hardware address=00e04c002bae所对应的位置,然后随便改其中一个值,点确定就不是提示有冲突了。

这便是XP发现IP地址冲突的过程。

分布式 dynamips+dyangen (更新于07.3.30)

更新内容:
很多网友都反映用此文方法行不通,现象为:分布在各计算机上的路由器能起来,但互联的端口是Down的,以至于ping 不通。在此特别感谢 flyxj 网友QQ联系到我才引起我的高度注视使问题得到解决,不会再给读者误导(本人能力是很有限的)。
原因经分析找到了,NET文件中有[localhost]一句,localhost 会被本地的hosts文件解析成127.0.0.1,想毕各位已经明白了吧,分布在各计算机上的路由器之间的连接是通过UDP=后边指定的端口通信的,由于127 和192不在同一子网,所以端口自然UP不起来了。
注意:笔者用最新的dynamips 0.2.7RC1和dynagen 0.90 实验不成功,有错误提示,google 了一下说是两个版本不匹配(晕)。请更新后仍不成功的朋友换本文推荐的版本试一下

dynamips 固然是个好东西,但其对内存苛刻的要求又让人头痛,虽说现在的内存比较便宜了,可对于像我这样的学生一族,又岂能承受的了。笔者01年买的电脑,一直也在升级,到现在才用上了512的内存。
那些有钱人新买来的电脑多是1G内存双核CPU,居然用来玩卡丁车,内存占用没上过500,这自然勾起我节约能源的爱国之心,用他们的电脑分担几台路由器,来完一大网络的模拟。“要学会花别人的钱”,嘿嘿,“要学会用别人的电脑”更恰当!于是笔者尝试了一下dynamips的分布式功能。

我们舍宿四台电脑,通过四口的傻瓜路由相连。不详细说了,充份发挥一下拓朴的优势!

Continue reading

dynamips 单臂路由实验

单臂路由是个很简单的实验,一直没有发现能支持单臂路由的ios,真是踏破铁鞋无觅处,得来全不费工夫,dynamips for 工大瑞普 的交换机版本就支持,ios文为 c3640-js-mz.124-10.bin(Enterprise and plus or Lan only),可以去网上找,或是工大瑞普论谈去下载。眼见为实,口说无凭。这下满足了自已的虚荣心,亲手做一下。
下边是实拓朴及net文件:

[file]attachment/200701/swlab.txt[/file]
实验配置如下(主机是用3620模拟的)
router 配置如下:
router(config)#interface FastEthernet0/0
router(config-if)#no ip address
router(config-if)#no shutdown
router(config)#interface FastEthernet0/0.1
router(config-if)#encapsulation dot1Q 1ip
router(config-if)#address 192.168.1.2 255.255.255.0

router(config)#interface FastEthernet0/0.2
router(config-if)#encapsulation dot1Q 2
router(config-if)#ip address 192.168.2.2 255.255.255.0

HOST配置如下:
HOST1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
HOST1(config)#interface FastEthernet0/0
HOST1(config-if)#ip address 192.168.1.1 255.255.255.0

HOST2(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
HOST2(config)#interface FastEthernet0/0
HOST2(config-if)#ip address 192.168.2.1 255.255.255.0

HOST3(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
HOST3(config)#interface FastEthernet0/0
HOST3(config-if)#ip address 192.168.1.3 255.255.255.0
到此不在同一VLAN的计算机就可以通信了。

笔者在实验过程中还发现,如果去掉HOST1、2、3路由器上的路由功能即命令:no ip routing。则HOST1、2、3的配置可以改成:
HOST1(config)#interface FastEthernet0/0
HOST1(config-if)#ip address 192.168.1.1 255.255.255.0

HOST2(config)#interface FastEthernet0/0
HOST2(config-if)#ip address 192.168.2.1 255.255.255.0

HOST3(config)#interface FastEthernet0/0
HOST3(config-if)#ip address 192.168.1.3 255.255.255.0
此配置和上边的区别在于去掉了静态路由,因为路由器去掉了routing功能。原则上来说还应该配上ip default-gateway <address>。address 为路由器接口与HOST处于同一VLAN的子接口IP。此配置中没有这条命令就可以实现VLAN间的互仿,有待于继续研究。

windows xp 网上邻居 故障解决

有关网上邻居的问题,问的人一直比较多,所以特写此文。
1、网上邻居基本工作原理(此部分可以跳过)
(此部分摘自《网上邻居内幕》一文)
当你通过网上邻居窗口打开整个网络时,你将看到一个工作组列表,再打开某个工作组,你将看到里面的计算机列表(也可在 DOS方式下用net view /domain:workgroupname命令得到),这就是我们所说的 Browsing List。工作组从本质上说就是共享一个浏览列表的一组计算机, 浏览列表是通过广播查询浏览主控服务器,由浏览主控服务器提供的。主控服务器维护本工作组中的浏览列表及指定其他工作组的主控服务器列表,为本工作组的其他计算机和其他来访本工作组的计算机提供浏览服务,每个工作组都会为每个传输协议选择一个浏览主控服务器,浏览主控服务器是该工作组中第一台启用文件及打印机共享功能的计算机。如果当前的浏览主控服务器关闭了系统,又没有其他计算机启用主控设置时,就要进行主控浏览器的选举。一台计算机发送一个选举报文,该报文包含了来自发送计算机的信息,选举报文向网络中广播,工作组中的每一台计算机都会用自身信息与选举报文进行比较,然后按照相应的规则优胜略汰,最终选出一台计算机为主控浏览服务器。每台启用了文件及打印机共享的计算机启动时会向网络广播宣告自己的存在,浏览主控服务器会取得这个宣告并将它放入自己维护的浏览列表中。当客户计算机想获得需要的网络资源列表时,首先会广播发出浏览请求,浏览主控服务器收到请求后,如果请求的是本组的浏览列表,则直接将客户所需的资源列表发回;如果请求的是其它工作组的浏览列表,浏览主控服务器会根据本身Browsing List中的记录找到相应工作组的主控浏览器返回给用户,用户可从那里得到它想要的浏览列表。很多时候网络中的计算机并不能正确更新浏览列表。当一台计算机正常关机时,它会向网络发出广播宣告,使浏览主控服务器及时将它从浏览列表中删除;而非正常关机后,或其它特殊原因,浏览列表里仍会把该条目保持很长一段时间(NT下是45分钟),这就是我们仍能在网络邻居里看到它的而不能仿问的原因.(更详细内幕请参看《网上邻居内幕》一文)
2、网络互仿可能出现的问题

①工作组模式中可能经常碰到能ping通对方,却不能仿问对方资源。(包括用UNC路径和网上邻居仿问)
②通仿问,便要求输入用户名密码,用户名为灰会的guest不能改。
③提示资源不存在或没有权限
一般上面的现象多是由下面几个原因导致的。
①默认情况下的简单文件共享
②组策略中相关的安全设置
③防火墙

(1)使用简单文件共享
我的电脑→工具→文件夹选项→查看→勾上“使用简单文件共享(推荐)”。
在这种方式下资源仿问用的是本地guest身份仿问的。而默认情况下guest是被禁用的,这样将不能仿问资源。解决方法为启用guest用户。控制面板→管理工具→本地安全策略→本地策略→安全选项里,“帐户:来宾帐户状态”改为已启用,找到“拒绝从网络仿问这台计算机”默认里边有guest,须把此项中的guest删掉,再找到:“帐户:使用空白密码的本地帐户只允许控制台登陆”,guest默认是没有密码的所以此项也要禁用。检查“网络仿问:本地帐户的共享和安全”是不是为“仅来宾……”。
(2)使认证方式共享
将"安全选项"中的“网络仿问:本地帐户的共享和安全”改为“经典……”,这时使用简单文件共享的勾会自动被去掉。禁用guest,启用“帐户:使用空白密码的本地帐户只允许控制台登陆”,此时要求帐户必须有密码。再次仿问资源就会提示输入用户名密码。输入对端计算机中存在的帐户密码即可。
(3)如果仿火墙是打开的话那,以上的工作只能是徒劳。如是xp自带仿火墙,在例处中要选中打印和文件共享或禁用。如果是第三方的须要打开137 138 139 445 端口或禁用,致于为什么,参看windows 网上邻居内幕一文。

注意:要在两台计算机上都进行如上配置,通信是双向的吗。

(有问题请留言)

不用路由器,实现不同网段(子网)计算机之间的通信

文章针对有IP网络基础知识,对osi和以太网有基本了解的人群!

此文章所有字眼均出自笔者本人(转帖请注明出处) ,如果不对还请高手指点,也希望收到自位中老手的意见或建议。
下面奔今天的主题
首先介绍一下,网关的作用,因为实现中要借助网关。
    路由器是三层的设备,主要协议为IP。三层设备主要负责寻址,通过查看自已通过各种动态路由协议或静态指定的路由表,来确定数据包的传送方向,路由器就像是站在十字路口的一个交警,如果有司机(数据包)不知道目的地就问这个交警,这个交警从大脑的数据库中检索到,这个司机要去的目的地,然后再确定到达目的应走哪个路口。计算机操作系统实现了OSI七层模型,当应用层发出网络请求后经由表示层、会话层、传输层(具体功能不在本文范围,请参看其它资料),要送到网络层加封网络层信息即IP地址,同时也要进行寻址(路由)。大部分的计算机只有自身使用的路由表,不会路由接收到的数据包,配置网关就相当于在自身的路由表中加入一个条目(在命今提示符下输入 route print 查看,特别注意,没有网关是没有这个条目的),所有不明去向的包都发送至网关,这就是网关的作用。这里假定网关为192.168.1.1 网卡IP为:192.168.1.123):

Network Destination        Netmask          Gateway         Interface       Metric
       0.0.0.0               0.0.0.0        192.168.1.1      192.168.1.123      20
Continue reading