标签归档:路由器

路由器

dynamips 单臂路由实验

单臂路由是个很简单的实验,一直没有发现能支持单臂路由的ios,真是踏破铁鞋无觅处,得来全不费工夫,dynamips for 工大瑞普 的交换机版本就支持,ios文为 c3640-js-mz.124-10.bin(Enterprise and plus or Lan only),可以去网上找,或是工大瑞普论谈去下载。眼见为实,口说无凭。这下满足了自已的虚荣心,亲手做一下。
下边是实拓朴及net文件:

[file]attachment/200701/swlab.txt[/file]
实验配置如下(主机是用3620模拟的)
router 配置如下:
router(config)#interface FastEthernet0/0
router(config-if)#no ip address
router(config-if)#no shutdown
router(config)#interface FastEthernet0/0.1
router(config-if)#encapsulation dot1Q 1ip
router(config-if)#address 192.168.1.2 255.255.255.0

router(config)#interface FastEthernet0/0.2
router(config-if)#encapsulation dot1Q 2
router(config-if)#ip address 192.168.2.2 255.255.255.0

HOST配置如下:
HOST1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
HOST1(config)#interface FastEthernet0/0
HOST1(config-if)#ip address 192.168.1.1 255.255.255.0

HOST2(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
HOST2(config)#interface FastEthernet0/0
HOST2(config-if)#ip address 192.168.2.1 255.255.255.0

HOST3(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
HOST3(config)#interface FastEthernet0/0
HOST3(config-if)#ip address 192.168.1.3 255.255.255.0
到此不在同一VLAN的计算机就可以通信了。

笔者在实验过程中还发现,如果去掉HOST1、2、3路由器上的路由功能即命令:no ip routing。则HOST1、2、3的配置可以改成:
HOST1(config)#interface FastEthernet0/0
HOST1(config-if)#ip address 192.168.1.1 255.255.255.0

HOST2(config)#interface FastEthernet0/0
HOST2(config-if)#ip address 192.168.2.1 255.255.255.0

HOST3(config)#interface FastEthernet0/0
HOST3(config-if)#ip address 192.168.1.3 255.255.255.0
此配置和上边的区别在于去掉了静态路由,因为路由器去掉了routing功能。原则上来说还应该配上ip default-gateway <address>。address 为路由器接口与HOST处于同一VLAN的子接口IP。此配置中没有这条命令就可以实现VLAN间的互仿,有待于继续研究。

ip default-network and ip route 0.0.0.0

一切的知识来源于外界,虽然这几天的文章有点范了和郭敬明同样的错误,但我不会受到法律的制裁。因为我没有以盈利为目的。用他人的知识来充实自已,只要自已有所收获就无所谓。更重要的是出现在自已blog上的文章且不是转帖,就要加上自已的总结和见解。但前题是,不要盈利,法律面前人人平等。

下面要写的这个问题就是参考自网友翻译的cisco文档。 关于 ip defuat-network 和 ip route 0.0.0.0 0.0.0.0 的区别。

学到ccnp的时候就会发现,ccna太片面了,要理解na的很多内容一定要有np知识的补充。

动态路由协议,要向其他路由器通告一条默认路由的方法有很多种,这种应用大多时候是在stub情况下比较多。下面一一介绍:

1.用ip defuat-network 。这个命令用在全局配置模式下,所以是全局有效的,对于所有的动态路由协议都有作用,配上此命令,路由协议就会向其他路由器通告一条默认路由,前提两台路由器运行相同路由协议,更重要的是,ip defuat-network 后面的网络号必须是此路由器(通告路由器)所知道的网络,动态学习到的或是静态指定的。所以这种方法比较可靠。

当用ip default-network指令设定多条默认路由时,administrative distance最短的成为最终的默认路由;如果有复数条路由distance值相等,那么在路由表(show ip route)中靠上的成为默认路由。
2.令一种就是用ip route 命令指定一条静态默认路由,然后重发布到动态路由协议,如RIP会自动发布ip route产生的默认路由而不须配制。应注意:EIGRP中只有当ip route 0.0.0.0 0.0.0.0 interface ,也就下一跳用的是本地接口,换而言之则是让路由器认为这是一条直连路由时,且在EIGRP协议配置里用network 0.0.0.0 发布此直连路由时,会向外通告一条默认路由(igrp 不支持此方法,其他协议没试)。如果有多条ip route 0.0.0.0 0.0.0.0指令,则流量会自动在多条链路上负载均衡。不推荐用此方法,因为0.0.0.0 就比较笼统。

补充:

同时使用ip default-network和ip route 0.0.0.0 0.0.0.0双方设定默认路由时,如果ip default-network设定的网络是直连(静态、且已知)的,那么它就成为默认路由;如果ip default-network指定的网络是由交换路由信息得来的,则ip route 0.0.0.0 0.0.0.0指定的表项成为默认路由。

3.通过在路由协议里配置default-information originate命令,完成向外通告默认路由。

注意:在igrp,eigrp中此命令不被支持。

不用路由器,实现不同网段(子网)计算机之间的通信

文章针对有IP网络基础知识,对osi和以太网有基本了解的人群!

此文章所有字眼均出自笔者本人(转帖请注明出处) ,如果不对还请高手指点,也希望收到自位中老手的意见或建议。
下面奔今天的主题
首先介绍一下,网关的作用,因为实现中要借助网关。
    路由器是三层的设备,主要协议为IP。三层设备主要负责寻址,通过查看自已通过各种动态路由协议或静态指定的路由表,来确定数据包的传送方向,路由器就像是站在十字路口的一个交警,如果有司机(数据包)不知道目的地就问这个交警,这个交警从大脑的数据库中检索到,这个司机要去的目的地,然后再确定到达目的应走哪个路口。计算机操作系统实现了OSI七层模型,当应用层发出网络请求后经由表示层、会话层、传输层(具体功能不在本文范围,请参看其它资料),要送到网络层加封网络层信息即IP地址,同时也要进行寻址(路由)。大部分的计算机只有自身使用的路由表,不会路由接收到的数据包,配置网关就相当于在自身的路由表中加入一个条目(在命今提示符下输入 route print 查看,特别注意,没有网关是没有这个条目的),所有不明去向的包都发送至网关,这就是网关的作用。这里假定网关为192.168.1.1 网卡IP为:192.168.1.123):

Network Destination        Netmask          Gateway         Interface       Metric
       0.0.0.0               0.0.0.0        192.168.1.1      192.168.1.123      20
继续阅读